2015 Si NAV radio on NON-NAV Civic HELP NO AUDIO!!!!! Problem Fix :-)

Discussion in 'Navigation, Security Systems, & Electrical' started by Jaybe, Feb 10, 2018.

  1. Jaybe

    Jaybe Well-Known Member

    Messages:
    28
    Location:
    Houston, TX
    Vehicle Model:
    Civic Si
    Body Style:
    Coupe
    Hi my friends, it have been a long time from my last post on this forum and I desperately need help for this one. Finally after more that 2 years looking for an OEM NAV unit for my (2015) Si I found one this week for a very good price, better than an aftermarket price, and I like to have my things OEM. Ok, everything works just perfect with the NAV unit on my NON-NAV Civic, the Nav system works perfect and today was a very stormy day here on Houston, the HD Radio that was the most important thing that I was looking to have is working and all the other little things but there is always a BIG BUT. There is NO AUDIO......... the Nav unit is missing one connector that my NON-Nav unit have, i think is for the external factory amp, is there any one that knows what to do to make the speakers work, maybe a retrofit harness or change some pins. Every single thing works with the Nav unit on my Civic but the AUDIO. I will post some picture and please someone HELP PLEASE.. Thanks.... IMG_1017.jpg IMG_1019.jpg IMG_1020.jpg IMG_1021.jpg IMG_1022.jpg s-l1600.jpg s-l16002.jpg
     
  2. webby
    • Staff
    • 2018 Toys For Tots

    webby Administrator

    Messages:
    49,141
  3. Jaybe

    Jaybe Well-Known Member

    Messages:
    28
    Location:
    Houston, TX
    Vehicle Model:
    Civic Si
    Body Style:
    Coupe
    I have seen that, but is totally different from the 2014-2015. If I can find what this connector is for maybe I can make this work. There is no function missing or not working with the Navi unit, all the cameras ( side and rear ) all steering controls, i-MID radio info, everything works but the audio. This is only an 8 pin connector and not all of the pins are occupied, maybe is a power control for the factory amp???? IMG_1017-2.jpg
     
  4. Jaybe

    Jaybe Well-Known Member

    Messages:
    28
    Location:
    Houston, TX
    Vehicle Model:
    Civic Si
    Body Style:
    Coupe
    A05E40CD-758A-4075-B782-5E4080F5084D.jpeg Not even the aftermarket harness with factory AMP to install an aftermarket unit have that connector. My Bluetooth works, HD radio works, USB works, HDMI works. ........... JUST NO AIDIO........
     
    Last edited: Feb 10, 2018
  5. webby
    • Staff
    • 2018 Toys For Tots

    webby Administrator

    Messages:
    49,141
    Because you don’t have the factory amp. The audio all goes to it
     
  6. Jaybe

    Jaybe Well-Known Member

    Messages:
    28
    Location:
    Houston, TX
    Vehicle Model:
    Civic Si
    Body Style:
    Coupe

    I think I do have the factory amp. 4 wites thats all I just did a phone call and the mic works, voice commend also works.
     
  7. webby
    • Staff
    • 2018 Toys For Tots

    webby Administrator

    Messages:
    49,141
  8. Jaybe

    Jaybe Well-Known Member

    Messages:
    28
    Location:
    Houston, TX
    Vehicle Model:
    Civic Si
    Body Style:
    Coupe
    I will double check when I get home but I’m pretty sure I have it because I checked not too long ago. OK but let me ask you, the NAV radio is supposed to have factory external amp or not, because I’m like 90% sure that my unit (the not Nav) has factory external Amp.
     
  9. webby
    • Staff
    • 2018 Toys For Tots

    webby Administrator

    Messages:
    49,141
    All non-si models with premium audio have an external amp. That goes for nav models. Si trims with or without nav have an external amp.
     
    fg3_colton likes this.
  10. fg3_colton

    fg3_colton Well-Known Member

    Messages:
    290
    Location:
    Tampa
    Vehicle Model:
    Civic, LX
    Body Style:
    Coupe
    So based off the previous replies, am I safe to assume that all non premium audio 9th gens (such as my LX) would have this problem if the HondaLink head unit was swapped in?

    Sent from my LG-LS993 using Tapatalk
     
  11. Jaybe

    Jaybe Well-Known Member

    Messages:
    28
    Location:
    Houston, TX
    Vehicle Model:
    Civic Si
    Body Style:
    Coupe
    EA2E6C8F-4F30-40B6-AC76-69BC3315BBFE.jpeg 08592A4D-A32F-47F8-A874-7D962F47867D.jpeg 74E483F7-82B4-417E-ABD3-093A08A6BEC3.jpeg 513219C9-9B9D-438E-AD7F-98F688270B52.jpeg WoW!!!! Finaly finish @ 3am. Ok, my Si have the external factory amp abd the NAV unit had an internal amplification. I noticed that there was no Subwoofer controll on the NAV unit, the conector missing on the NAV unit is for the Subwoofer. Now comes the good part, I open both radios and start comparing components and the big difference was on the lower board. On my unit there was no amplifiers and the NAV had one big amplifier transistor with a heatsink right next to the fan. Then I mount the upper board with the 16gb SD card on my unit with the no NAV lower board and just in case with the front board attached to the LCD touchscreen. Thats it, I just retrofit my NO-NAV Si to a NAV - HD Radio Unit Working 100%. Now to my next project, retrofit the Auto A/C on my Si, not interested on the Automatic controls, just on the Digital LCD control. There is some changes on the harness for the additional sensors, thats no probles because I just whant the look of the LCD display on the A/C control. I connected and it turns on but will not make any changes on the A/C like the blower, blend boots and will not turn the A/C Compressor on.
     
    webby likes this.
  12. webby
    • Staff
    • 2018 Toys For Tots

    webby Administrator

    Messages:
    49,141
    Yeah, but look above. He made it work
     
  13. fg3_colton

    fg3_colton Well-Known Member

    Messages:
    290
    Location:
    Tampa
    Vehicle Model:
    Civic, LX
    Body Style:
    Coupe
    This is a lot for me to take in here, so sorry if i misinterpret something. I just have a couple questions, First, which radio did you come from? My assumption was the non touch premium audio head unit. If that is the case, how and what exactly did you have to do to the mother board on the old radio, to get it to work with the new one. I cant really tell based off the pictures. I've been wanting to do this same swap on my LX for the longest time, really glad you posted this! One last question, did you car come with the HDMI port? If not, is it causing any problems with the new head unit?
     
  14. Jaybe

    Jaybe Well-Known Member

    Messages:
    28
    Location:
    Houston, TX
    Vehicle Model:
    Civic Si
    Body Style:
    Coupe

    The Si trim all comes with premium audio, The only difference is that some cones with NAV and others without it. My Si had the No NAV but the with the external AMP and Subwoofer. My problem was that after some research i found out that the NAV unit that I install on my Si came from a hybrid and had no premium sound with NAV/HD Radio. That means that the AMP is inside the radio not external and my factory is external, knowing that i just temove the upper main board thats the one with the SD card and install it on my radio with the external AMP with Subwoofer and everything work like a charm. The only thing missing is the wide rear view camera because the no Nav Si comes with a regular rear view camera. But I’m already on the look up off a Wide angle rear view camera, just have to make sure the harness is the same at the trunk lid. If you have any question just contact me.
     
    webby and fg3_colton like this.
  15. fg3_colton

    fg3_colton Well-Known Member

    Messages:
    290
    Location:
    Tampa
    Vehicle Model:
    Civic, LX
    Body Style:
    Coupe
    Yea I'll have a few, I'm very interested in this swap. I have an LX without the premium audio, and without the touch screen. So I'm assuming that for the most part, this swap would be plug and play-ish. Since mine does not have an external amp, I wouldn't have to swap the boards, correct?

    Sent from my LG-LS993 using Tapatalk
     
  16. Jaybe

    Jaybe Well-Known Member

    Messages:
    28
    Location:
    Houston, TX
    Vehicle Model:
    Civic Si
    Body Style:
    Coupe
    My friend, because you don't have the 7" touchscreen 1st check what harness you have on your car. All depends on the harness, I don't think you have the AUX (HDMI/USB), GPS Antenna, Subwoofer and maybe some others. But my friend there is always something you can do it all depends on how much $$$ you are willing to spend on a project. Check this link below.

    https://www.hondapartscheap.com/aut...fuel-cat/navigation-system-gps-antenna-2-scat
     
    fg3_colton likes this.
  17. JDToumanian

    JDToumanian Well-Known Member

    Messages:
    1
    Reviving an old thread here but... What about XM Radio? My 2014 Civic CNG has the 7" touch screen but no NAV or XM. My Subaru has XM and I like it... I'd like to add XM to my Civic if possible. I know there are Bluetooth XM units or other aftermarket options, but I'd like to explore adding the Honda XM option. Jaybe, when you added the NAV radio, did it also add the XM option? Thanks.

    Regards,
    Jon
     
  18. Balt15Si

    Balt15Si Member

    Messages:
    33
    I'm going to try the same thing Jaybe, and my car has the sub, that means external amp correct?
    So I got my Nav unit, and it does have the built in amp, indicated by a heat sink and fan, am I correct about this ?
    Therefore it will not have that sub out socket correct?
    So I need to take the lower board out of my navless unit and put it into the Nav unit? It will then have the sub out socket?

    Thanks for your post, I wouldn't be trying this without it !
     
  19. webby
    • Staff
    • 2018 Toys For Tots

    webby Administrator

    Messages:
    49,141
  20. Balt15Si

    Balt15Si Member

    Messages:
    33
    I tried, no word from him at all, so I guess I'm on my own with this, no one else has tried this ? but from dissecting his posts I think I pretty much understand it all, I just gotta get that GPS antenna next
     

Share This Page