• A large amount of updates and changes have been implemented. Users who have been using tapaptalk will need to access the site in their phone browser. You should see a big difference between the desktop/tablet/phone styles to make navigation and site options easier to use. If you come across any strange behavior, or errors, please report them in this thread. If you have any issues logging into the site, please delete all 9thcivic cookies and then log into the site. https://9thcivic.com/forum/threads/site-changes.16518/

Rev Hang - KTuner

Christian AC

Well-Known Member
13
3
Ontario, Canada
Vehicle Model
Civic Si
Body Style
Sedan
So I'm sure there is a lot about the rev hang for the 9th gen civics here already, but I couldn't find anything to see if I'm the only one experiencing this with my KTuner.

So according to the site I'm suppose to put the Overrun Throttle Compensation to 0% to get rid of the rev hang. I did that, and when I'm driving normally on the roads its gone and shifting fine, but the problem is when I'm on the highway shifting at 3K plus... When I'm shifting on the highway it feels like there's a delay when I let off the clutch and shift (not smooth at all). When I noticed this I put the Overrun Throttle Compensation back to 100% and the issue on the highway was gone.

I just wanted to know if anyone else with a KTuner was having the same issue as me and if so how did you fix the issue.

Also, just wanted to add that I do the clutch delay valve delete to see if it would help at 0%, but nothing.
 

webby

Administrator
Admin
Toys For Tots
52,959
22,718
Is it not a check box? I don’t have it to know, but this makes it sound like there is a box to disable?
 

Christian AC

Well-Known Member
13
3
Ontario, Canada
Vehicle Model
Civic Si
Body Style
Sedan
Is it not a check box? I don’t have it to know, but this makes it sound like there is a box to disable?
I believe the check box is for the 10th gen civics, and the Overrun Throttle Compensation is for the 9th gen civic.

I heard back from KTuner support and they said that they don't have the issue I'm having with their 2012 Civic for 5 years...

 

webby

Administrator
Admin
Toys For Tots
52,959
22,718
I see it now. It does claim 100% is set at the factory, and setting it to "0" should eliminate the rev hang? Do you have a custom tune for your car? I don't know what mods you have or if you're working with a tuner?

 

Christian AC

Well-Known Member
13
3
Ontario, Canada
Vehicle Model
Civic Si
Body Style
Sedan
I see it now. It does claim 100% is set at the factory, and setting it to "0" should eliminate the rev hang? Do you have a custom tune for your car? I don't know what mods you have or if you're working with a tuner?

I just have a K&N drop in filter, and a 2.75 inch which exits to a 3.5 inch muffler.

When I purchased the KTuner the dealer said that I would be able to use "Tune 1"

You think that could be an issue?
 

Attachments

  • ktuner.png
    ktuner.png
    546.2 KB · Views: 3

webby

Administrator
Admin
Toys For Tots
52,959
22,718
that seems super weird to me that they list it as UP to a pre cat delete downpipe/exhaust/intake for tune1. People have said their cars ran insanely rich and horrible with a downpipe/cat delete and required a custom tune once they did a downpipe. If you don't have a downpipe/cat delete I feel like that tune would not work well. I'm not saying it would cause the rev hang issue, but I feel like the tune wouldn't be good? I don't know of anyone off hand who's on ktuner without a custom tune, and most others seem to be using hondata flashpro. I guess ktuner support would know better on that, or you could reach out to an etuner company.
 

Christian AC

Well-Known Member
13
3
Ontario, Canada
Vehicle Model
Civic Si
Body Style
Sedan
that seems super weird to me that they list it as UP to a pre cat delete downpipe/exhaust/intake for tune1. People have said their cars ran insanely rich and horrible with a downpipe/cat delete and required a custom tune once they did a downpipe. If you don't have a downpipe/cat delete I feel like that tune would not work well. I'm not saying it would cause the rev hang issue, but I feel like the tune wouldn't be good? I don't know of anyone off hand who's on ktuner without a custom tune, and most others seem to be using hondata flashpro. I guess ktuner support would know better on that, or you could reach out to an etuner company.
I reached out to KTuner support and they said they aren't sure what could cause the issue... So I'm going to go back to the factory tune and disable the rev hang and see if that will fix it.

Thanks for the support @webby!
 

Janz3n

Well-Known Member
1,219
721
Ontario Canada
Vehicle Model
Honda Civic SI
Body Style
sedan
I reached out to KTuner support and they said they aren't sure what could cause the issue... So I'm going to go back to the factory tune and disable the rev hang and see if that will fix it.

Thanks for the support @webby!
I know this is flashpro but it may help. i still had rev hang until i changed the overrun fuel cut settings. not sure if ktuner has similar settings.
 

Christian AC

Well-Known Member
13
3
Ontario, Canada
Vehicle Model
Civic Si
Body Style
Sedan
When I got home yesterday I went and reflashed my ECU to the factory base calibration from Tune 1, removed rev hang and the issue was fixed... I guess it was the tune that was messing around with the rev hang?

I will try changing the overrun fuel cut settings with Tune 1 and let you know how it goes.
 

Janz3n

Well-Known Member
1,219
721
Ontario Canada
Vehicle Model
Honda Civic SI
Body Style
sedan
When I got home yesterday I went and reflashed my ECU to the factory base calibration from Tune 1, removed rev hang and the issue was fixed... I guess it was the tune that was messing around with the rev hang?

I will try changing the overrun fuel cut settings with Tune 1 and let you know how it goes.
how did it go?
 
Top