Cruise Control

Discussion in 'Mechanical Problems & Technical Chat' started by Ethan Hall, Jul 25, 2017.

  1. Ethan Hall

    Ethan Hall New Member

    Messages:
    1
    My main cruise control light will come on but when I try to set the cruise nothing happens. Does anyone know what the problem might be and how to fix it?
     
  2. Nix

    Nix J├Âtunn Moderator

    Messages:
    10,765
    Location:
    Lew-vul, KY
    Body Style:
    It's A Fast Pig!
    Year/trim? If you turn on the main cruise mode and then hit "set" it can take a few seconds to engage.

    EX: if you want the cruise at 65mph, turn on cruise, drive up to 65 and hit set, accelerate up to say 68 and then ease off the gas slowly. The car should catch and stay at 65. It can take a few seconds for the system to engage and hold, hence the pass, set, and ease off.

    Someone else correct me if I'm wrong.
     
  3. Enigma346

    Enigma346 Well-Known Member

    Messages:
    225
    Location:
    Virginia Beach, VA
    Vehicle Model:
    Civic Si
    Body Style:
    Coupe
    Also, if your foot is even barely touching the clutch pedal, it will not engage. Mine was touching it and I didn't know it and got new wondering why mine wouldn't engage at that time.
     
  4. webby
    • Staff
    • 2018 Toys For Tots

    webby Administrator

    Messages:
    49,134
    After turning cruise on you have to hit the "set" button to get it to the speed you want. I believe set is on the bottom of the circle (right side of steering wheel).
     
  5. aZnCdn

    aZnCdn Well-Known Member

    Messages:
    20
    Did you ever find a fix for this? Mine stopped working, when I set the speed the car would stutter a bit then the cruise would turn off. Seems to me it might be a relay fuse given the following characteristics: it was working, then kind of working, then not working.
     

Share This Page