Passenger Airbag OFF Blinking Constantly 2015 Civic Sedan

Discussion in 'Mechanical Problems & Technical Chat' started by bonestockcivic, Nov 13, 2018.

  1. bonestockcivic

    bonestockcivic New Member

    Messages:
    2
    Hello everyone, this problem has occurred since I bought the car as a salvage restored vehicle. The Passenger Airbag OFF light blinks at about a 50% duty cycle all of the time. I tried swapping to another seat with track and passenger weight sensor unit (data processor) and no change. I've since swapped back to the original seat since it was cleaner. I'll note that when I bought the car, the passenger seat harness assembly was not zip tied to the seat like it was from the factory, so somebody was already trying to figure it out.

    I just got out the meter tonight and checked 3 of 4 wires from the passenger weight sensor unit (the last wire goes to the DLC so it won't be part of my problem). Below is the Passenger seat sensor schematic, the SRS controller connector "B" pin table, and two pics explaining my confusion. When I probed from the passenger weight sensor unit wire (green) that goes to SRS controller connector "B" pin 21, I get an OPEN from the front, but when I go to the back, I get continuity. I listed info about the passenger side airbag continuity to show that I should see continuity on pin 21 from the front as well. I've never heard of a contact separating in the middle, so I'm at a loss.

    Any input from you guys is greatly appreciated!

    [​IMG]
    [​IMG]
    [​IMG]

    [​IMG]
     
  2. webby
    • Staff
    • 2018 Toys For Tots

    webby Administrator

    Messages:
    49,587
    Did you try popping the green wire out of the connector and inspecting it and the harness plug on that pin?
     
  3. bonestockcivic

    bonestockcivic New Member

    Messages:
    2
    I was checking continuity at dusk and this is what happens when you do that. I'll have to go back in again to verify, but a second look this morning at the pic and the pin table tells me that I was measuring on the front at pin 10, not 21. I'll give it a second go this weekend when I have time.
     

Share This Page