• A large amount of updates and changes have been implemented. Users who have been using tapaptalk will need to access the site in their phone browser. You should see a big difference between the desktop/tablet/phone styles to make navigation and site options easier to use. If you come across any strange behavior, or errors, please report them in this thread. If you have any issues logging into the site, please delete all 9thcivic cookies and then log into the site. https://9thcivic.com/forum/threads/site-changes.16518/

Diagnostic code P0420

John_chafin

Well-Known Member
81
14
Georgia
Vehicle Model
Civic
Body Style
Si
I did a diagnostic on my 2012 civic si sedan today for a check emission light. It ran the code p0420 which with my research seems to be a bad O2 sensor? I'm just making sure this is correct and what my option of fixing it would be. Thanks guys!
 

Dennis Rockholt

9k Alll Day
1,952
869
Franklin, TN
Vehicle Model
370Z Fairlady aka "Nismo"
Body Style
Coupe
Did you recently install any sort of exhaust mods?
 

Dennis Rockholt

9k Alll Day
1,952
869
Franklin, TN
Vehicle Model
370Z Fairlady aka "Nismo"
Body Style
Coupe
Well you probably damaged one of the 2 sensors during install I'd assume
 

Dennis Rockholt

9k Alll Day
1,952
869
Franklin, TN
Vehicle Model
370Z Fairlady aka "Nismo"
Body Style
Coupe
I'd say the dealer...just because you want em to be good quality.
 

bardley

Active Member
That code is a catalyst efficiency below threshold code because the header you just installed has no cat. You can either get it fixed from a tune (which you should get any way) or try spark plug defoulers.
 

John_chafin

Well-Known Member
81
14
Georgia
Vehicle Model
Civic
Body Style
Si
That code is a catalyst efficiency below threshold code because the header you just installed has no cat. You can either get it fixed from a tune (which you should get any way) or try spark plug defoulers.
I did get it tuned but it came on after I got home from getting it tuned.
 

John_chafin

Well-Known Member
81
14
Georgia
Vehicle Model
Civic
Body Style
Si
^that. Needs turned off in flashpro
We'll this morning I was driving and when I was down shifting my exhaust got extremely loud and vibrated underneath me, is this one of the symptoms of the o2 sensor not being cut off when he tuned it?
 

Phroze

Well-Known Member
159
157
Oklahoma City, Ok
Vehicle Model
Civic Si
Body Style
Coupe
just check it yourself if your settings, should be under sensors or something like that and you might need to have advanced parameters enabled.
 

webby

Administrator
Admin
Toys For Tots
52,311
22,442
We'll this morning I was driving and when I was down shifting my exhaust got extremely loud and vibrated underneath me, is this one of the symptoms of the o2 sensor not being cut off when he tuned it?
It's doing to make more noise being new. Lots of catless downpipe owners say it changes after some use. Nothing to do with o2
 

John_chafin

Well-Known Member
81
14
Georgia
Vehicle Model
Civic
Body Style
Si
This doesn't sound like it's setting in though. This sounds like something wrong I'm not sure.
 

Nix

Jötunn Moderator
10,765
8,162
Lew-vul, KY
Body Style
It's A Fast Pig!
Check ya bolts and mounts. Other people have needed a stiffer exhaust mount to keep it from hitting in a couple places.
 
Top