• A large amount of updates and changes have been implemented. Users who have been using tapaptalk will need to access the site in their phone browser. You should see a big difference between the desktop/tablet/phone styles to make navigation and site options easier to use. If you come across any strange behavior, or errors, please report them in this thread. If you have any issues logging into the site, please delete all 9thcivic cookies and then log into the site. https://9thcivic.com/forum/threads/site-changes.16518/

Official 'What did you do to your car today?' Thread

Nevtec

Well-Known Member
356
243
Lincoln, Nebraska
Vehicle Model
civic
Body Style
FG2
I put some vinyl on today, I think it looks pretty good for as cheap as it was.
 

Bulkybear

Well-Known Member
1,665
749
Yes i noticed more response in the revs i replaced it trying to get rid or a bad cat/backfire possibly???????? And after install only when she starts cold it the exhaust pops when u rev it and its boggy like its being restricted by one of the cats !!!!! Im thinkin the primary/downpipe cat is the culprit lol back to the drawing board all for the love of hondas lol
Pretty sure thats just how the warm up phase for our cars is. When the ecu is in warm up mode (cold start or right after you start it) it runs pretty rich (exhaust pops) and is really unresponsive, I pretty much had to floor it to rev to 5k. Out of warm up its fine though. Its normal.
 

Redrocket1

Well-Known Member
149
70
Kalamazoo, MI
Vehicle Model
Civic Si
Body Style
Coupe
I finally got around to installing my 24mm progress bar a few days ago, but it was making a noise at low speeds. This morning I got under there again and tightened the end links, but the threaded bolt sheared right in half... So I scrapped the adjustable end links and put the stock ones back on. Noise is gone. I guess I'll never find out the exact cause of the noise. But it was either the links weren't adjusted right or the link bolts weren't tight enough.
As for my impression of the RSB, I took a shot in the dark at guessing which end was the stiffer setting, but have since learned that I chose the softest setting. I can still feel the difference from stock, but I'm going to try the stiffer setting out tomorrow maybe.
 

323

Modifier
5,252
3,682
Chicago
Vehicle Model
Civic Si
Body Style
Sedan
I finally got around to installing my 24mm progress bar a few days ago, but it was making a noise at low speeds. This morning I got under there again and tightened the end links, but the threaded bolt sheared right in half... So I scrapped the adjustable end links and put the stock ones back on. Noise is gone. I guess I'll never find out the exact cause of the noise. But it was either the links weren't adjusted right or the link bolts weren't tight enough.
As for my impression of the RSB, I took a shot in the dark at guessing which end was the stiffer setting, but have since learned that I chose the softest setting. I can still feel the difference from stock, but I'm going to try the stiffer setting out tomorrow maybe.
Did you grease the end links?
 
Top